User Tools

Site Tools


en:orx:tutorials:visualstudio:cloning_and_building_orx_on_visual_studio

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
en:orx:tutorials:visualstudio:cloning_and_building_orx_on_visual_studio [2019/07/14 19:51 (8 months ago)]
iarwain
en:orx:tutorials:visualstudio:cloning_and_building_orx_on_visual_studio [2019/07/18 01:36 (7 months ago)] (current)
Line 1: Line 1:
-====== Building the Orx library on Windows with Visual Studio 2015/2017 ======+====== Building the Orx library on Windows with Visual Studio 2015/2017/2019 ======
  
 Before you can build the Orx library, you will need to clone it using ''​git''​. First [[en:​tutorials:​cloning_orx_from_github|follow these instructions to clone and initialize Orx]], then come back. Before you can build the Orx library, you will need to clone it using ''​git''​. First [[en:​tutorials:​cloning_orx_from_github|follow these instructions to clone and initialize Orx]], then come back.
Line 10: Line 10:
  
 <WRAP center round important 90%> <WRAP center round important 90%>
-**IMPORTANT**:​ //Visual Studio 2017 can give an error during compilation,​ generating a request to update the SDK from Windows 8.1 to Windows 10. To solve this is very simple, right click on the project solution (property), and select "​Retarget Solution"​. This will open a window in the center where it automatically asks you if you want to update the solution to SDK 10. click "​Ok"​ and in 2 seconds you have solved the problem.//+**IMPORTANT**:​ //Visual Studio 2017 or 2019 can give an error during compilation,​ generating a request to update the SDK from Windows 8.1 to Windows 10. To solve this is very simple, right click on the project solution (property), and select "​Retarget Solution"​. This will open a window in the center where it automatically asks you if you want to update the solution to SDK 10. click "​Ok"​ and in 2 seconds you have solved the problem.// 
 + 
 +However please ensure you do have the SDK installed, as it is required with VS2017 and greater.
 </​WRAP>​ </​WRAP>​
  
Line 42: Line 44:
 ===== Troubleshooting ===== ===== Troubleshooting =====
  
-There are no items here just yet, but if you encounter any errors using Visual Studio 2015 or 2017, please let us know [[http://​forum.orx-project.org|on the forum]]. We'll fix it up quickly and add your errors here for others.+There are no items here just yet, but if you encounter any errors using Visual Studio 20152017 or 2019, please let us know [[http://​forum.orx-project.org|on the forum]]. We'll fix it up quickly and add your errors here for others.
  
  
en/orx/tutorials/visualstudio/cloning_and_building_orx_on_visual_studio.txt · Last modified: 2019/07/18 01:36 (7 months ago) (external edit)